How to Factory Reset a Particle Argon IoT Board

If you are a Particle developer and using Argon IoT board, you may be interested in this article. When you need to unclaim your particle IoT board for some reasons such as transferring the ownership and make another person to reclaim the board using his/her account, you would try the factory reset tutorial that the Particle team published on the Particle community (Here is the link). However, when you try to reclaim the board using the Particle app, you may see an error message:

It’s weird, right? You factory reset the device, but the app says the device might be connected to any other devices! This article is how to solve this issue and successfully reclaim the device in a clean slate.

irst, you have to go through the factory reset steps that the Particle team suggests (see this link):

1. Begin holding the MODE button down.
2. While holding the MODE button down, tap the RESET button briefly.
3. After 3 seconds the core will begin blinking yellow, KEEP HOLDING the MODE button.
4. After 10 seconds the core will begin blinking white. When this happens the factory reset process has begun. Let go of the MODE button.
5. When it stops blinking white, it should begin blinking blue, indicating that it is listening for WiFi credentials.

Occasionally, the particle board would not enter the DFU mode (blinking yellow) for some reasons at step 3 and just be blinking dark blue. I had this issue when I tried to factory reset a newly purchased board. If you have this issue, connect the board to the laptop using USB, open the terminal, and type:

$ particle usb dfu

particle usb is a Particle command line interface (CLI) command. If you do not know how to use it, please visit this CLI reference page. Once the LED starts blinking yellow, try the factory setup again from the beginning. It will work now.

fter factory resetting the Argon board, we need to set the setup done flag to enable to reclaim the board. To do that, connect the board to the laptop using USB and open the terminal. Then, type:

$ particle usb setup-done

It’s all set. If setting the setup done flag doesn't work and you still see that pop up message, Unable to find your mesh device. ... , when trying to claim the board, just reboot your smartphone and try again.

I have not tried this trick for any other types of Particle board. So I am not guaranteeing that this trick would work for other types of boards such as Photon. But if you have the same issue, please try the same trick and share your experience!

A computer scientist enthusiastic about enabling our surroundings smart and even autonomous! KAIST PhD, now at MIT as a Postdoc

Get the Medium app

A button that says 'Download on the App Store', and if clicked it will lead you to the iOS App store
A button that says 'Get it on, Google Play', and if clicked it will lead you to the Google Play store